Enginatics always stays up to date with the latest technology. So right after the availability of Oracle E-Business Suite 12.2.9 was announced, our team was eager to upgrade our EBS Demo 12.2.8 instance to the latest release, so anyone can test Blitz Report™ on the most recent software. Blitz Report™ is the fastest reporting solution for Oracle E-Business Suite. Steps that we have taken to perform the upgrade are presented below.

Applying prerequisite patches


References:

Oracle E-Business Suite Release 12.2.9 Readme (Doc ID 2495027.1)
Oracle E-Business Suite 12.2.9 Now Available

Upgrade Database to 11.2.0.4 or higher

Our EBS 12.2.8 installation has already included Oracle database 12c. So this step will not be covered. Besides database upgrade alone is worth dedicated article. Please refer to upgrade instructions for your specific Oracle Database version on MOS.

Apply Required Database Patches

Determine latest database PSU
Latest patch at moment of research was 29699220 – Combo of OJVM Component 12.1.0.2.190716 DB PSU + DB PSU 12.1.0.2.190716
It includes two patches:

29494060 - Database Release Update Database Patch Set Update 12.1.0.2.190716
29774383 - Oracle JavaVM Component 12.1.0.2.190716

Download and unzip latest OPatch
Before patches application OPatch always should be updated to avoid unexpected issues.

[oracle@r1228a patches]$ cd $ORACLE_HOME
[oracle@r1228a 12.1.0]$ mv OPatch/ OPatch_bkp
[oracle@r1228a 12.1.0]$ cp ~/patches/p6880880_121010_Linux-x86-64.zip .
[oracle@r1228a 12.1.0]$ unzip p6880880_121010_Linux-x86-64.zip

Determine patches conflicts
If any conflicts are faced, please refer to MOS Documents to resolve them. Alternatively, My Oracle Support Patch Conflict Checker Tool can be used or Oracle Service Request can be created.

$ cd 29699220/29494060
$ opatch prereq CheckConflictAgainstOHWithDetail -ph ./

Prereq “checkConflictAgainstOHWithDetail” passed.

$ cd 29699220/29774383
$ opatch prereq CheckConflictAgainstOHWithDetail -ph ./

Prereq “checkConflictAgainstOHWithDetail” passed.

Shutdown apps and db services

$ . /u01/install/APPS/EBSapps.env run
$ cd $ADMIN_SCRIPTS_HOME
$ ./adstpall.sh
$ . /u01/install/APPS/12.1.0/EBSDB_apps.env
$ echo “shu immediate”|sqlplus ‘/as sysdba’
$ lsnrctl stop $ORACLE_SID

Apply patches with OPatch
Start screen to save session in case of network interruptions. If screen utility is not available on your server, I recommend to install it. It’s very handy tool.

$ screen -S patching
$ cd 29494060
$ opatch apply
$ egrep -i “error|fail|ORA-|ac-|rc-/u01/install/APPS/12.1.0/cfgtoollogs/opatch/opatch2018-10-11_10-21-18AM_1.log
$ cd ../29774383
$ opatch apply
$ egrep -i “error|fail|ORA-|ac-|rc-/u01/install/APPS/12.1.0/cfgtoollogs/opatch/opatch2018-10-11_10-23-02AM_1.log

Load Modified SQL Files into the Database
Datapatch can be run once for both OJVM and DB PSU in upgrade mode

SQL> sqlplus ‘/as sysdba’
SQL> startup upgrade
$ cd $ORACLE_HOME/OPatch
$ ./datapatch -verbose
SQL> sqlplus ‘/as sysdba’
SQL> shutdown immediate;
SQL> startup

Recompile invalid objects

$ cd $ORACLE_HOME/rdbms/admin
$ sqlplus ‘/as sysdba’
SQL> @utlrp.sql

Apply latest WLS PSU to patch fs

Remove conflicting patches applied on top of previous WLS PSU:

{
$ . /u01/install/APPS/EBSapps.env patch
$ cd $FMW_HOME/utils/bsu
$FMW_HOME/utils/bsu/bsu.sh -remove -patchlist=9RME,TR6Y,9XLF,47D2,ISBJ -prod_dir=$FMW_HOME/wlserver_10.3
}

Apply Patch 29633432: WLS PATCH SET UPDATE 10.3.6.0.190716 (MXLE) to patch fs

$ cp MXLE.jar /u01/install/APPS/fs2/FMW_Home/utils/bsu/cache_dir/
$ cp patch-catalog_26707.xml $FMW_HOME/utils/bsu/cache_dir/
$ cd $FMW_HOME/utils/bsu
$FMW_HOME/utils/bsu/bsu.sh -install -patch_download_dir=$FMW_HOME/utils/bsu/cache_dir -patchlist=MXLE -prod_dir=$FMW_HOME/wlserver_10.3

Check Weblogic version after patch application

$ . $FMW_HOME/wlserver_10.3/server/bin/setWLSEnv.sh
$ java weblogic.version
 
WebLogic Server 10.3.6.0.190716 PSU Patch for BUG29633432 Thu May 23 04:18:02 PDT 2019

Apply DB ETCC patches

Run ETCC report on DB tier
Run the latest version of the EBS Technology Codelevel Checker via Patch 17537119. ETCC patches are required as a pre-requisite for latest AD and TXK RUP patches.

$ cd /tmp/patches/patches/ETCC
$ ./checkDBpatch.sh

List of patches to be applied:

p8975044_12102171017_Linux-x86-64.zip
p29619616_12102190115_Linux-x86-64.zip
p25599890_121020_Generic.zip
p29628339_12102190416_Linux-x86-64.zip
p29587136_12102190416_Linux-x86-64.zip
p25099339_12102190416_Linux-x86-64.zip
p28682351_121025_Generic.zip
p28542455_12102190416_Linux-x86-64.zip

All above patches are contained in 29778098 EBS RELEASE 12.2 CONSOLIDATED DATABASE FIXES FOR JUL 2019

Shutdown database instance, identify and rollback conflicting patches.

$ echo “shu immediate”|sqlplus ‘/as sysdba’
$ lsnrctl stop $ORACLE_SID
 
$ cd [patch number]
$ opatch prereq CheckConflictAgainstOHWithDetail -ph ./
{
opatch rollback -id 28062791 -silent
}

Apply patches
Required patches list:

p8975044_12102171017_Linux-x86-64.zip
p29619616_12102190115_Linux-x86-64.zip
p25599890_121020_Generic.zip
p29628339_12102190416_Linux-x86-64.zip
p29587136_12102190416_Linux-x86-64.zip
p25099339_12102190416_Linux-x86-64.zip
p28682351_121025_Generic.zip
p28542455_12102190416_Linux-x86-64.zip

For all above patches commands to apply are:

$ unzip ‘p*zip’
$ cd [patch number]
$ opatch apply
$ egrep -i “error|fail|ORA-|ac-|rc-

Post installation tasks
Run datapatch and recompile invalid objects

$ lsnrctl start $ORACLE_SID
$ cd $ORACLE_HOME/OPatch
$ echo “startup”|sqlplus ‘/as sysdba’
$ ./datapatch -verbose
$ sqlplus ‘/as sysdba’
SQL>@?/rdbms/admin/utlrp.sql
exit

Re-run ETCC report to ensure, that all patches are applied now

[oracle@apps patches]$ . ~/EBSDB_database.env
[oracle@apps patches]$ ./checkDBpatch.sh
>>All the required one-off bugfixes are present in Database ORACLE_HOME.

Set Database Parameters
Parameters are needed to be adjusted as follows:

optimizer_adaptive_features=false
“_disable_actualization_for_grant”=true

Commands to setup parameters are:

SQL> alter system set “_disable_actualization_for_grant”=true;
SQL> alter system set optimizer_adaptive_features=false;

Apply MT ETCC patches

Run ETCC report on MT tier

Run the latest version of the EBS Technology Codelevel Checker via Patch 17537119

$ cd /tmp/patches/patches/ETCC
[oracle@apps patches]$ ./checkMTpatch.sh
 
=========================================================================
PATCH RECOMMENDATION SUMMARY
=========================================================================
-------------------------------------------------------------------------------
Oracle Forms and Reports 10.1.2.3.0
-------------------------------------------------------------------------------
  Patch 27491934
    - Filename: p27491934_101232_LINUX.zip
 
 
-------------------------------------------------------------------------------
Oracle Fusion Middleware (FMW) - Web Tier 11.1.1.9.0
-------------------------------------------------------------------------------
  Patch 27369643
    - Filename: p27369643_111190_Linux-x86-64.zip
 
  Patch 27301611
    - Filename: p27301611_111190_Linux-x86-64.zip
 
 
-------------------------------------------------------------------------------
RSF within FMW Web tier 11.1.0.7.0
-------------------------------------------------------------------------------
  Patch 22290164
    - Filename: p22290164_111070_Linux-x86-64.zip
 
 
-------------------------------------------------------------------------------
Oracle Fusion Middleware (FMW) - oracle_common 11.1.1.9.0
-------------------------------------------------------------------------------
  Patch 27120730
    - Filename: p27120730_111190_Generic.zip
 
  Patch 27212806
    - Filename: p27212806_111190_Generic.zip
 
  Patch 28708563
    - Filename: p28708563_111190_Generic.zip
 
 
-------------------------------------------------------------------------------
Oracle WebLogic Server (WLS) 10.3.6.0.190716
-------------------------------------------------------------------------------
  Patch 17319481 [SU Patch [IJG4]]
    - Filename: p17319481_10360190716_Generic.zip
 
  Patch 19259028 [SU Patch [IIYG]]
    - Filename: p19259028_10360190716_Generic.zip
 
  Patch 25373406 [SU Patch [9UBP]]
    - Filename: p25373406_10360190716_Generic.zip
 
  Patch 27158972 [SU Patch [X1NW]]
    - Filename: p27158972_10360190716_Generic.zip

A consolidated zip file with the required application tier patches is
available on My Oracle Support via patch 29778100

Apply MT ETCC patches
For convenience passwords can be assigned to variables, so they don’t have to be provided manually.

$ read -s appspass
$ read -s systempass
$ read -s wlspass

Start new patching cycle (WLS admin server will be started automatically on run fs)

{ echo $appspass; echo $systempass; echo $wlspass; }|adop phase=prepare

Possible error:

Statement Handler Error Code: 4063
Statement Handler Error Message: ORA-04063: package body "APPS.AD_ZD_ADOP" has errors (DBD ERROR: OCIStmtExecute)
Reference of statement-handler is valid, not attempting database reconnect.
Failed to execute SQL statement:
select AD_ZD_ADOP.GET_INVALID_NODES() from dual
Error Message:
ORA-04063: package body "APPS.AD_ZD_ADOP" has errors (DBD ERROR: OCIStmtExecute) [UNEXPECTED]Error determining whether this is a multi-node instance
 
Statement Handler Error Code: 4063
Statement Handler Error Message: ORA-04063: package body "APPS.AD_ZD_ADOP" has errors (DBD ERROR: OCIStmtExecute)
Reference of statement-handler is valid, not attempting database reconnect.
Failed to execute SQL statement:
select ad_zd_adop.validate_session_id('') from dual
 
Error Message:
ORA-04063: package body "APPS.AD_ZD_ADOP" has errors (DBD ERROR: OCIStmtExecute)
 
[STATEMENT] Please run adopscanlog utility, using the command

Solution per Doc ID 2175698.1:

$ sqlplus '/as sysdba'
SQL>grant execute on SYS.DBMS_METADATA_UTIL to apps;
SQL>alter package APPS.AD_ZD_ADOP compile body;
SQL>exit;

Follow patch recommendation summary and apply patches. Patches below are tab-formatted showing dependencies. All pre-requisite patches should be applied before dependent patch.

Oracle Forms and Reports 10.1.2.3.0

[-]6880880 latest opatch
[-]27491934
	[+]14825718
	[+]6640838
	[+]8551790

Extract latest opatch before patches application

$ . ~/EBSapps.env patch
$ cd $ORACLE_HOME
$ mv OPatch/ OPatch_bkp
$ cp ~/patches/p6880880_101000_Linux-x86-64.zip .
$ unzip p6880880_101000_Linux-x86-64.zip
$ rm -f p6880880_101000_Linux-x86-64.zip

Apply patches using following commands:

$ . ~/EBSapps.env patch
$ cd 27491934 
$ opatch apply
$ egrep -i “error|warning|fail|ora-|ac-|rc-"/u01/install/APPS/fs2/EBSapps/10.1.2/.patch_storage/27491934/Apply_27491934_08-26-2019_15-14-28.log"

Oracle Fusion Middleware (FMW) – Web Tier 11.1.1.9.0

[-]27369643
[-]27301611

Apply to patch fs Oracle Home

$ . ~/EBSapps.env patch
$ . $FMW_HOME/SetWebtier.env
#Verify that opatch is running from right OH
$ which opatch
$ echo $ORACLE_HOME

Installation instructions:

$ cd [patch number]
$ opatch apply
$ egrep -i "error|warning|fail|ora-|ac-|rc-" /u01/install/APPS/fs2/FMW_Home/webtier/cfgtoollogs/opatch/27369643_Aug_26_2019_15_21_13/apply2019-08-26_15-21-13PM_1.log \
/u01/install/APPS/fs2/FMW_Home/webtier/cfgtoollogs/opatch/27301611_Aug_26_2019_15_23_42/apply2019-08-26_15-23-42PM_1.log

RSF within FMW Web tier 11.1.0.7.0

[-]22290164

Apply to patch fs Oracle Home

$ . ~/EBSapps.env patch
$ . $FMW_HOME/SetWebtier.env
#Verify that opatch is running from right OH
$ which opatch
$ echo $ORACLE_HOME

Installation instructions:

$ cd 22290164
$ opatch apply
$ egrep -i "error|warning|fail|ora-|ac-|rc-"  /u01/install/APPS/fs2/FMW_Home/webtier/cfgtoollogs/opatch/22290164_Aug_26_2019_15_28_52/apply2019-08-26_15-28-52PM_1.log

Oracle Fusion Middleware (FMW) – oracle_common 11.1.1.9.0

[-]6880880 latest opatch 111000
[-]27120730
[-]27212806
[-]28708563

Extract latest opatch

$ . ~/EBSapps.env patch
$ . $FMW_HOME/SetOracleCommon.env
$ cd $ORACLE_HOME
$ mv OPatch/ OPatch_bkp
$ cp ~/patches/p6880880_111000_Linux-x86-64.zip .
$ unzip p6880880_111000_Linux-x86-64.zip
$ rm -f p6880880_111000_Linux-x86-64.zip

Apply to patch fs Oracle Home

$ . ~/EBSapps.env patch
$ . $FMW_HOME/SetOracleCommon.env
#Verify that opatch is running from right OH
$ which opatch
$ echo $ORACLE_HOME
$ cd [patchnum] (in case 27120730 need to go to 27120730/oui)  
$ opatch apply

Check logfiles for errors:

egrep -i "error|warning|fail|ora-|ac-|rc-" \
/u01/install/APPS/fs2/FMW_Home/oracle_common/cfgtoollogs/opatch/27120730_Aug_26_2019_15_39_00/apply2019-08-26_15-39-00PM_1.log \
/u01/install/APPS/fs2/FMW_Home/oracle_common/cfgtoollogs/opatch/27212806_Aug_26_2019_15_41_56/apply2019-08-26_15-41-56PM_1.log \
/u01/install/APPS/fs2/FMW_Home/oracle_common/cfgtoollogs/opatch/28708563_Aug_26_2019_15_44_42/apply2019-08-26_15-44-42PM_1.log

Oracle WebLogic Server (WLS) 10.3.6.0.180717

  Patch 17319481 [SU Patch [IJG4]]
    - Filename: p17319481_10360190716_Generic.zip
 
  Patch 19259028 [SU Patch [IIYG]]
    - Filename: p19259028_10360190716_Generic.zip
 
  Patch 25373406 [SU Patch [9UBP]]
    - Filename: p25373406_10360190716_Generic.zip
 
  Patch 27158972 [SU Patch [X1NW]]
    - Filename: p27158972_10360190716_Generic.zip

Increase memory allocation to prevent bsu fail

vi /u01/install/APPS/fs1/FMW_Home/utils/bsu/bsu.sh

Change from

MEM_ARGS=-Xms512m -Xmx1024m -XX:+UseParallelGC”

to

MEM_ARGS=-Xms1024m -Xmx2048m -XX:+UseParallelGC”

Apply patches

. ~/EBSapps.env patch
$ cp *IJG4* *IIYG* *9UBP* *X1NW* patch-catalog_26729.xml patch-catalog_26734.xml patch-catalog_26750.xml patch-catalog_26735.xml /u01/install/APPS/fs2/FMW_Home/utils/bsu/cache_dir/
$ cd $FMW_HOME/utils/bsu
$ $FMW_HOME/utils/bsu/bsu.sh -install -patch_download_dir=$FMW_HOME/utils/bsu/cache_dir -patchlist=IJG4,IIYG,9UBP,X1NW -prod_dir=$FMW_HOME/wlserver_10.3

Re-run ETCC report to confirm that now all required patches present.
Apply patch environment as all above patches were installed to patch fs.

[oracle@apps ETCC]$ . ~/EBSapps.env patch
 ./checkMTpatch.sh

All required one-offs are confirmed as present.

Apply Consolidated Seed Table Upgrade

This step is applicable only for new installation customers and customers upgrading from Oracle E-Business Suite Release 12.2.2 to Release 12.2.9. Skipping this step as we have 12.2.8 installation.


Apply the Latest AD and TXK Delta RUPS

Reference:
Applying the Latest AD and TXK Release Update Packs to Oracle E-Business Suite Release 12.2 (Doc ID 1617461.1)

Patch research

[-]26834480 R12.AD.C.Delta.11
	[-]28280348:R12.AD.C //Critical AD patch
[-]28840822 R12.TXK.C.Delta.11
	[-]29965377:R12.TXK.C //Critical TXK patch
	[-]29781255:R12.TXK.C //Critical TXK patch

Pre-steps
Execute adgrants script by following the instructions in the readme of Patch 26834480:

1. Create $ORACLE_HOME/appsutil/admin on the database server.

2. Compare the version of adgrants.sql(UNIX) in $APPL_TOP/admin to that in patch directory.

$ grep ‘$Header’ $ORACLE_HOME/appsutil/admin/adgrants.sql
 
        REM $Header: adgrants.sql 120.67.12020000.60 2018/04/26 02:32:13 jwsmith ship $
 
$ grep ‘$Header’ /backup/patches/EBS12.2/ADTKX/26834480/admin/adgrants.sql
 
        REM $Header: adgrants.sql 120.67.12020000.65 2019/04/02 22:47:38 jwsmith ship $

3. Copy the higher version of adgrants.sql (UNIX) to $ORACLE_HOME/appsutil/admin.

$ cp -iv /backup/patches/EBS12.2/ADTKX/26834480/admin/adgrants.sql /u01/install/APPS/12.1.0/appsutil/admin

4. Set the environment to point to ORACLE_HOME on the database server.

$ . ~/EBSDB_database.env

5. Use SQL*Plus to run the script:

$ sqlplus /nolog
SQL> @$ORACLE_HOME/appsutil/admin/adgrants.sql APPS

Got warnings:

2019/08/27 07:28:14         453 ad.plsql.ad_zd_sys.GIVE_PRIVILEGE          WARNING
ORA-00942: table or view does not exist, SQL: grant SELECT on "DBMS_UPG_STATUS$" to "APPS"
 
2019/08/27 07:28:14         453 ad.plsql.ad_zd_sys.GIVE_PRIVILEGE          WARNING
ORA-00942: table or view does not exist, SQL: grant SELECT on "DBMS_UPG_STATUS$" to "SYSTEM" with grant option
 
2019/08/27 07:28:15         453 ad.plsql.ad_zd_sys.GIVE_PRIVILEGE          WARNING
ORA-04042: procedure, function, package, or package body does not exist, SQL: grant EXECUTE on "DBMS_SCHEMA_COPY" to "APPS"
 
2019/08/27 07:28:15         453 ad.plsql.ad_zd_sys.GIVE_PRIVILEGE          WARNING
ORA-04042: procedure, function, package, or package body does not exist, SQL: grant EXECUTE on "DBMS_SCHEMA_COPY" to "SYSTEM" with grant option
 
2019/08/27 07:28:15         453 ad.plsql.ad_zd_sys.GIVE_PRIVILEGE          WARNING
ORA-00942: table or view does not exist, SQL: grant WRITE on "DIRECTORY FND_DIAG_DIR" to "APPS"
 
2019/08/27 07:28:15         453 ad.plsql.ad_zd_sys.GIVE_PRIVILEGE          WARNING
ORA-00942: table or view does not exist, SQL: grant READ on "DIRECTORY FND_DIAG_DIR" to "APPS"

Solution:

Per Doc ID 2507343.1 those messages can be ignored.

Apply patches

read -s appspass
read -s systempass
read -s wlspass
 
. ~/EBSapps.env run
echo $appspass|adop -status -detail

Apply R12.AD.C.Delta.11 along with NLS and critical AD patches with “merge=yes” option:

{ echo $appspass; echo $systempass; echo $wlspass; }|adop phase=apply patches=26834480,26834480_ZHS:u26834480.drv,26834480_I:u26834480.drv,26834480_F:u26834480.drv,26834480_D:u26834480.drv,26834480_AR:u26834480.drv,28280348 merge=yes patchtop=/backup/patches/EBS12.2/ADTKX/

Apply R12.TXK.C.Delta.11 along with NLS and critical TXK patches with “merge=yes” option:

{ echo $appspass; echo $systempass; echo $wlspass; }|adop phase=apply patches=28840822,28840822_ZHS:u28840822.drv,28840822_I:u28840822.drv,28840822_F:u28840822.drv,28840822_D:u28840822.drv,28840822_AR:u28840822.drv,29965377,29781255 merge=yes patchtop=/backup/patches/EBS12.2/ADTKX/
 
adopscanlog -latest=yes
egrep -i "error|warning|fail|ora-|ac-|rc-" /u01/install/APPS/fs_ne/EBSapps/log/adop/68/20190827_081313/apply/apps/ADOP_MRG_20190827_1566886413/log/u_2457993231.log
 
egrep -i "error|warning|fail|ora-|ac-|rc-" /u01/install/APPS/fs_ne/EBSapps/log/adop/68/20190827_073158/apply/apps/ADOP_MRG_20190827_1566883939/

Update Database Tier to Latest Code

Will perform that step after all EBS patches are applied and fs cutover completed.

Apply Oracle E-Business Suite 12.2.9 Release Update Pack


Finally after applying all pre-requisite patches upgrade to 12.2.9 can be performed. For our instance Path B — Existing Customers (Release 12.2.8) should be followed.

Apply patches with adop

{ echo $appspass; echo $systempass; echo $wlspass; }|adop phase=apply patches=28840850 patchtop=/backup/patches/EBS12.2/EBS1229RUP

Apply Oracle E-Business Suite Release 12.2.9 Online Help along with NLS

{ echo $appspass; echo $systempass; echo $wlspass; }|adop phase=apply patches=28840900,28840900_ZHS:u28840900.drv,28840900_I:u28840900.drv,28840900_F:u28840900.drv,28840900_D:u28840900.drv,28840900_AR:u28840900.drv merge=yes patchtop=/backup/patches/EBS12.2/EBS1229RUP

Check logfiles for errors

adopscanlog -latest=yes
 
egrep -i "error|warning|fail|ora-|ac-|rc-" /u01/install/APPS/fs_ne/EBSapps/log/adop/68/20190827_090009/apply/apps/28840850/log/u28840850.log
egrep -i "error|warning|fail|ora-|ac-|rc-" /u01/install/APPS/fs_ne/EBSapps/log/adop/68/20190827_103109/apply/apps/28840900/log/u28840900.log

Finish adop patching cycle

$ { echo $appspass; echo $systempass; echo $wlspass; }| adop phase=finalize
$ { echo $appspass; echo $systempass; echo $wlspass; }| adop phase=cutover
$ . ~/EBSapps.env run
$  { echo $appspass; echo $systempass; echo $wlspass; }|adop phase=cleanup
$  { echo $appspass; echo $systempass; echo $wlspass; }|adop phase=fs_clone

Post-steps

Compile invalid objects

select owner, object_name, object_type from dba_objects where status<>’VALID’;
exec utl_recomp.recomp_parallel(4);

Verify security configurations (required)

The administrator must log in to Oracle E-Business Suite using the local login page (http(s)://[host]:[port]/OA_HTML/AppsLocalLogin.jsp) to navigate to the console and unlock the system.

Update Database Tier to Latest Code

1. Execute the admkappsutil.pl utility to create the appsutil.zip file in $INST_TOP/admin/out.

$ perl $AD_TOP/bin/admkappsutil.pl

2. On the database tier (as the ORACLE user):

Source the environment for ORACLE_HOME.

$ cd $ORACLE_HOME
$ . $ORACLE_HOME/$CONTEXT_NAME.env

3. Uncompress appsutil.zip, under $ORACLE_HOME.

$ cd $ORACLE_HOME
$ unzip -o appsutil.zip

4. Run AutoConfig on $ORACLE_HOME.

$ORACLE_HOME/appsutil/scripts/$CONTEXT_NAME/adautocfg.sh
 
$ egrep -i “error|warning|fail|ora-|ac-|rc-/u01/install/APPS/12.1.0/appsutil/log/EBSDB_apps/10121547/adconfig.log

5. Run AutoConfig on the run file system. Run AutoConfig on all application tier nodes (as the APPLMGR user) by executing the applicable command:

$ sh $INST_TOP/admin/scripts/adautocfg.sh

Healthcheck


Restart application tier services and verify that following checks are passed:

– EBS login works.
– Forms open
– Number of target and actual concurrent processes are equal.
– Test concurrent requests successfully completed. Example of such requests: “CP PLSQL Regression Test”, “Active Users”
– Other components depending on instance-specific configuration. For example: workflow mailer.

Picture 1: Oracle EBS 12.2.9 home page

Picture 2: Oracle EBS 12.2.9 Administer Concurrent Managers form

Picture 3: Oracle EBS 12.2.9 Concurrent Requests form

Conclusion


Please keep in mind that every EBS upgrade is unique due to different software, hardware versions, customizations. So it is better not to use above instructions on production environment. But I hope that this article will help you to understand EBS upgrade process and prepare your own project.